北海道苫小牧市出身の初老PGが書くブログ

永遠のプログラマを夢見る、苫小牧市出身のおじさんのちらしの裏

TurboGearsが1.0.4.X系に

Jan 21, 2008: TurboGears 1.0.4.2 released.、なんですけど。

SQLObjectに依存しないようにtgsetup.pyが変更されてます。どうやらこのせいで、tgsetup.pyだけではSQLObjectが入らず、インストールが完了しないっぽいです。*1


一週間ほど前に、こっちの古いtgsetup.pyではインストールできてたんで、これ使うとうまく行くかもしれません。*2



1/30追記。こちらで報告して頂きましたm(_ _)m。

*1:自分では試せてないですが:-) Win機で、SQLObjectが入らなくてエラーになることを確認。easy_install SQLObject でSQLObjectを入れても、導入されるバージョンが新しすぎてcontrollers.pyでエラーが出る。

*2:自分では試せてないですが:-) WinXPでうまくいくことを確認。